watchdog requires Python '>=2.7, <3.6' but the running Python is 3.7.3
Not sure if this is the correct way to report it, but I tried.
Steps to reproduce
- Install latest stable Debian AMD64 (10 Buster) and update all packages to latest stable.
- Follow the Debian installation instructions up to
pip install -r api/requirements.txt
Collecting watchdog~=0.10.0 (from -r api/requirements/base.txt (line 74)) Using cached https://files.pythonhosted.org/packages/2d/fb/183f63f23349a77e0597c3fa0146cccc48189441849d6bb4c2be8496f693/watchdog-0.10.5.tar.gz watchdog requires Python '>=2.7, <3.6' but the running Python is 3.7.3
Installation fails after this as installed Python version seems to be too new for watchdog.
What is expected?
Maybe list the expected Python 3 version required to run Funkwhale in the installation documents for Debian/Arch installations? Possibly also include link to installing said version in a pyenv, instead of depending on system package manager?
- Tried installing Funkwhale on the latest stable Debian version, as I am already running a few other services on the same server and didn't want to get a new one for Funkwhale.
- Buster has been out for 17 months now so I believe it isn't unreasonable to expect that server admins, especially new ones, might go for Buster over Stretch if they follow the distro specific guides instead of the quick install one.
Setup: Debian 10 amd64 on bare-metal hardware | nginx
Funkwhale version(s) affected: latest stable(?)