Commit c57d252a authored by Eliot Berriot's avatar Eliot Berriot
Browse files

Merge branch '185-database-encoding' into 'develop'

Resolve "Add a warning about required database encoding"

Closes #185

See merge request funkwhale/funkwhale!167
parents 34ce18ff a79f42b0
Document that the database should use an utf-8 encoding (#185)
......@@ -32,13 +32,22 @@ Create the project database and user:
.. code-block:: shell
CREATE DATABASE funkwhale;
CREATE DATABASE "scratch"
WITH ENCODING 'utf8'
LC_COLLATE = 'en_US.utf8'
LC_CTYPE = 'en_US.utf8';
CREATE USER funkwhale;
GRANT ALL PRIVILEGES ON DATABASE funkwhale TO funkwhale;
Assuming you already have :ref:`created your funkwhale user <create-funkwhale-user>`,
you should now be able to open a postgresql shell:
.. warning::
It's importing that you use utf-8 encoding for your database,
otherwise you'll end up with errors and crashes later on when dealing
with music metedata that contains non-ascii chars.
.. code-block:: shell
sudo -u funkwhale -H psql
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment