Update dependency @typescript-eslint/eslint-plugin to v5.44.0

Tested-by: Marge <!2184>
Part-of: <!2184>
5 jobs for !2184 with renovate/develop-typescript-eslint-monorepo in 5 minutes and 41 seconds (queued for 2 seconds)
latest merge request