Fix #1099: Dropped python 3.5 support. Python 3.6 is the minimum required version

6 jobs for drop-compat in 5 minutes and 26 seconds (queued for 3 seconds)