poetry.lock 240 KB
Newer Older
1
2
[[package]]
name = "aiohttp"
3
version = "3.8.1"
4
5
6
7
8
9
description = "Async http client/server framework (asyncio)"
category = "main"
optional = false
python-versions = ">=3.6"

[package.dependencies]
10
11
12
aiosignal = ">=1.1.2"
async-timeout = ">=4.0.0a3,<5.0"
asynctest = {version = "0.13.0", markers = "python_version < \"3.8\""}
13
attrs = ">=17.3.0"
14
15
charset-normalizer = ">=2.0,<3.0"
frozenlist = ">=1.1.1"
16
multidict = ">=4.5,<7.0"
17
typing-extensions = {version = ">=3.7.4", markers = "python_version < \"3.8\""}
18
19
20
yarl = ">=1.0,<2.0"

[package.extras]
21
speedups = ["aiodns", "brotli", "cchardet"]
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36

[[package]]
name = "aioredis"
version = "1.3.1"
description = "asyncio (PEP 3156) Redis support"
category = "main"
optional = false
python-versions = "*"

[package.dependencies]
async-timeout = "*"
hiredis = "*"

[[package]]
name = "aioresponses"
Georg Krause's avatar
Georg Krause committed
37
version = "0.7.3"
38
39
40
41
42
43
44
45
description = "Mock out requests made by ClientSession from aiohttp package"
category = "dev"
optional = false
python-versions = "*"

[package.dependencies]
aiohttp = ">=2.0.0,<4.0.0"

46
47
48
49
50
51
52
53
54
55
56
[[package]]
name = "aiosignal"
version = "1.2.0"
description = "aiosignal: a list of registered asynchronous callbacks"
category = "main"
optional = false
python-versions = ">=3.6"

[package.dependencies]
frozenlist = ">=1.1.0"

57
58
[[package]]
name = "amqp"
59
version = "5.1.0"
60
61
62
63
64
65
description = "Low-level AMQP client for Python (fork of amqplib)."
category = "main"
optional = false
python-versions = ">=3.6"

[package.dependencies]
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
vine = ">=5.0.0"

[[package]]
name = "anyio"
version = "3.5.0"
description = "High level compatibility layer for multiple asynchronous event loop implementations"
category = "main"
optional = false
python-versions = ">=3.6.2"

[package.dependencies]
idna = ">=2.8"
sniffio = ">=1.1"
typing-extensions = {version = "*", markers = "python_version < \"3.8\""}

[package.extras]
doc = ["packaging", "sphinx-rtd-theme", "sphinx-autodoc-typehints (>=1.2.0)"]
test = ["coverage[toml] (>=4.5)", "hypothesis (>=4.0)", "pytest (>=6.0)", "pytest-mock (>=3.6.1)", "trustme", "contextlib2", "uvloop (<0.15)", "mock (>=4)", "uvloop (>=0.15)"]
trio = ["trio (>=0.16)"]
85
86
87
88
89
90
91
92
93
94
95

[[package]]
name = "appnope"
version = "0.1.2"
description = "Disable App Nap on macOS >= 10.9"
category = "main"
optional = false
python-versions = "*"

[[package]]
name = "arrow"
96
version = "1.2.2"
97
98
99
100
101
102
103
104
105
106
107
description = "Better dates & times for Python"
category = "main"
optional = false
python-versions = ">=3.6"

[package.dependencies]
python-dateutil = ">=2.7.0"
typing-extensions = {version = "*", markers = "python_version < \"3.8\""}

[[package]]
name = "asgiref"
108
version = "3.5.2"
109
110
111
description = "ASGI specs, helper code, and adapters"
category = "main"
optional = false
112
python-versions = ">=3.7"
113
114
115
116
117
118
119
120
121

[package.dependencies]
typing-extensions = {version = "*", markers = "python_version < \"3.8\""}

[package.extras]
tests = ["pytest", "pytest-asyncio", "mypy (>=0.800)"]

[[package]]
name = "async-timeout"
122
version = "4.0.2"
123
124
125
description = "Timeout context manager for asyncio programs"
category = "main"
optional = false
126
127
128
129
python-versions = ">=3.6"

[package.dependencies]
typing-extensions = {version = ">=3.6.5", markers = "python_version < \"3.8\""}
130
131
132
133
134

[[package]]
name = "asynctest"
version = "0.13.0"
description = "Enhance the standard unittest package with features for testing asyncio libraries"
135
category = "main"
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
optional = false
python-versions = ">=3.5"

[[package]]
name = "atomicwrites"
version = "1.4.0"
description = "Atomic file writes."
category = "dev"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*"

[[package]]
name = "attrs"
version = "21.4.0"
description = "Classes Without Boilerplate"
category = "main"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*"

[package.extras]
dev = ["coverage[toml] (>=5.0.2)", "hypothesis", "pympler", "pytest (>=4.3.0)", "six", "mypy", "pytest-mypy-plugins", "zope.interface", "furo", "sphinx", "sphinx-notfound-page", "pre-commit", "cloudpickle"]
docs = ["furo", "sphinx", "zope.interface", "sphinx-notfound-page"]
tests = ["coverage[toml] (>=5.0.2)", "hypothesis", "pympler", "pytest (>=4.3.0)", "six", "mypy", "pytest-mypy-plugins", "zope.interface", "cloudpickle"]
tests_no_zope = ["coverage[toml] (>=5.0.2)", "hypothesis", "pympler", "pytest (>=4.3.0)", "six", "mypy", "pytest-mypy-plugins", "cloudpickle"]

[[package]]
name = "autobahn"
163
version = "22.3.2"
164
165
166
description = "WebSocket client & server library, WAMP real-time framework"
category = "main"
optional = false
Georg Krause's avatar
Georg Krause committed
167
python-versions = ">=3.7"
168
169

[package.dependencies]
Georg Krause's avatar
Georg Krause committed
170
171
172
cryptography = ">=3.4.6"
hyperlink = ">=21.0.0"
txaio = ">=21.2.1"
173
174

[package.extras]
Georg Krause's avatar
Georg Krause committed
175
accelerate = ["wsaccel (>=0.6.3)"]
176
all = ["zope.interface (>=5.2.0)", "twisted (>=20.3.0)", "attrs (>=20.3.0)", "wsaccel (>=0.6.3)", "python-snappy (>=0.6.0)", "msgpack (>=1.0.2)", "ujson (>=4.0.2)", "cbor2 (>=5.2.0)", "py-ubjson (>=0.16.1)", "flatbuffers (>=1.12)", "pyopenssl (>=20.0.1)", "service_identity (>=18.1.0)", "pynacl (>=1.4.0)", "pytrie (>=0.4.0)", "pyqrcode (>=1.2.1)", "cffi (>=1.14.5)", "argon2_cffi (>=20.1.0)", "passlib (>=1.7.4)", "cffi (>=1.14.5)", "xbr (>=21.2.1)", "cbor2 (>=5.2.0)", "zlmdb (>=21.2.1)", "twisted (>=20.3.0)", "web3 (>=5.16.0)", "rlp (>=2.0.1)", "py-eth-sig-utils (>=0.4.0)", "py-ecc (>=5.1.0)", "eth-abi (>=2.1.1)", "mnemonic (>=0.19)", "base58 (>=2.1.0)", "ecdsa (>=0.16.1)", "py-multihash (>=2.0.1)", "jinja2 (>=2.11.3)", "yapf (==0.29.0)", "spake2 (>=0.8)", "hkdf (>=0.0.3)", "PyGObject (>=3.40.0)", "xbr (>=21.2.1)", "cbor2 (>=5.2.0)", "zlmdb (>=21.2.1)", "twisted (>=20.3.0)", "web3 (>=5.16.0)", "rlp (>=2.0.1)", "py-eth-sig-utils (>=0.4.0)", "py-ecc (>=5.1.0)", "eth-abi (>=2.1.1)", "mnemonic (>=0.19)", "base58 (>=2.1.0)", "ecdsa (>=0.16.1)", "py-multihash (>=2.0.1)", "jinja2 (>=2.11.3)", "yapf (==0.29.0)", "spake2 (>=0.8)", "hkdf (>=0.0.3)"]
Georg Krause's avatar
Georg Krause committed
177
compress = ["python-snappy (>=0.6.0)"]
178
dev = ["awscli", "backports.tempfile (>=1.0)", "bumpversion (>=0.5.3)", "codecov (>=2.0.15)", "flake8 (>=3.5.0)", "humanize (>=0.5.1)", "passlib", "pep8-naming (>=0.3.3)", "pip (>=9.0.1)", "pyenchant (>=1.6.6)", "pyflakes (>=1.0.0)", "pyinstaller (>=4.2)", "pylint (>=1.9.2)", "pytest-aiohttp", "pytest-asyncio (>=0.14.0)", "pytest-runner (>=2.11.1)", "pytest (>=3.4.2)", "pyyaml (>=4.2b4)", "qualname", "sphinx-autoapi (>=1.7.0)", "sphinx (>=1.7.1)", "sphinx_rtd_theme (>=0.1.9)", "sphinxcontrib-images (>=0.9.1)", "tox-gh-actions (>=2.2.0)", "tox (>=2.9.1)", "twine (>=3.3.0)", "twisted (>=18.7.0)", "txaio (>=20.4.1)", "watchdog (>=0.8.3)", "wheel (>=0.36.2)", "yapf (==0.29.0)", "mypy (>=0.610)"]
Georg Krause's avatar
Georg Krause committed
179
180
181
encryption = ["pyopenssl (>=20.0.1)", "service_identity (>=18.1.0)", "pynacl (>=1.4.0)", "pytrie (>=0.4.0)", "pyqrcode (>=1.2.1)"]
nvx = ["cffi (>=1.14.5)"]
scram = ["cffi (>=1.14.5)", "argon2_cffi (>=20.1.0)", "passlib (>=1.7.4)"]
182
serialization = ["msgpack (>=1.0.2)", "ujson (>=4.0.2)", "cbor2 (>=5.2.0)", "py-ubjson (>=0.16.1)", "flatbuffers (>=1.12)"]
Georg Krause's avatar
Georg Krause committed
183
twisted = ["zope.interface (>=5.2.0)", "twisted (>=20.3.0)", "attrs (>=20.3.0)"]
184
185
ui = ["PyGObject (>=3.40.0)"]
xbr = ["xbr (>=21.2.1)", "cbor2 (>=5.2.0)", "zlmdb (>=21.2.1)", "twisted (>=20.3.0)", "web3 (>=5.16.0)", "rlp (>=2.0.1)", "py-eth-sig-utils (>=0.4.0)", "py-ecc (>=5.1.0)", "eth-abi (>=2.1.1)", "mnemonic (>=0.19)", "base58 (>=2.1.0)", "ecdsa (>=0.16.1)", "py-multihash (>=2.0.1)", "jinja2 (>=2.11.3)", "yapf (==0.29.0)", "spake2 (>=0.8)", "hkdf (>=0.0.3)"]
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219

[[package]]
name = "automat"
version = "20.2.0"
description = "Self-service finite-state machines for the programmer on the go."
category = "main"
optional = false
python-versions = "*"

[package.dependencies]
attrs = ">=19.2.0"
six = "*"

[package.extras]
visualize = ["graphviz (>0.5.1)", "Twisted (>=16.1.1)"]

[[package]]
name = "backcall"
version = "0.2.0"
description = "Specifications for callback functions passed in to an API"
category = "main"
optional = false
python-versions = "*"

[[package]]
name = "billiard"
version = "3.6.4.0"
description = "Python multiprocessing fork with improvements and bugfixes"
category = "main"
optional = false
python-versions = "*"

[[package]]
name = "black"
220
version = "22.3.0"
221
222
223
224
225
226
description = "The uncompromising code formatter."
category = "dev"
optional = false
python-versions = ">=3.6.2"

[package.dependencies]
227
click = ">=8.0.0"
228
mypy-extensions = ">=0.4.3"
229
pathspec = ">=0.9.0"
230
platformdirs = ">=2"
231
tomli = {version = ">=1.1.0", markers = "python_version < \"3.11\""}
232
typed-ast = {version = ">=1.4.2", markers = "python_version < \"3.8\" and implementation_name == \"cpython\""}
233
typing-extensions = {version = ">=3.10.0.0", markers = "python_version < \"3.10\""}
234
235
236
237
238
239
240
241
242

[package.extras]
colorama = ["colorama (>=0.4.3)"]
d = ["aiohttp (>=3.7.4)"]
jupyter = ["ipython (>=7.8.0)", "tokenize-rt (>=3.2.0)"]
uvloop = ["uvloop (>=0.15.2)"]

[[package]]
name = "bleach"
243
version = "4.1.0"
244
245
246
description = "An easy safelist-based HTML-sanitizing tool."
category = "main"
optional = false
247
python-versions = ">=3.6"
248
249
250
251
252
253
254
255

[package.dependencies]
packaging = "*"
six = ">=1.9.0"
webencodings = "*"

[[package]]
name = "boto3"
256
version = "1.24.7"
257
258
259
description = "The AWS SDK for Python"
category = "main"
optional = false
260
python-versions = ">= 3.7"
261
262

[package.dependencies]
263
botocore = ">=1.27.7,<1.28.0"
264
jmespath = ">=0.7.1,<2.0.0"
265
s3transfer = ">=0.6.0,<0.7.0"
266
267
268

[package.extras]
crt = ["botocore[crt] (>=1.21.0,<2.0a0)"]
269
270
271

[[package]]
name = "botocore"
272
version = "1.27.7"
273
274
275
description = "Low-level, data-driven core of boto 3."
category = "main"
optional = false
276
python-versions = ">= 3.7"
277
278

[package.dependencies]
279
jmespath = ">=0.7.1,<2.0.0"
280
281
282
283
python-dateutil = ">=2.1,<3.0.0"
urllib3 = ">=1.25.4,<1.27"

[package.extras]
284
crt = ["awscrt (==0.13.8)"]
285
286
287
288
289
290
291
292
293
294
295

[[package]]
name = "cached-property"
version = "1.5.2"
description = "A decorator for caching properties in classes."
category = "main"
optional = false
python-versions = "*"

[[package]]
name = "cachetools"
Georg Krause's avatar
Georg Krause committed
296
version = "5.0.0"
297
298
299
description = "Extensible memoizing collections and decorators"
category = "main"
optional = false
Georg Krause's avatar
Georg Krause committed
300
python-versions = "~=3.7"
301
302
303

[[package]]
name = "celery"
304
version = "5.2.7"
305
306
307
description = "Distributed Task Queue."
category = "main"
optional = false
308
python-versions = ">=3.7"
309
310
311

[package.dependencies]
billiard = ">=3.6.4.0,<4.0"
JuniorJPDJ's avatar
JuniorJPDJ committed
312
click = ">=8.0.3,<9.0"
313
314
click-didyoumean = ">=0.0.3"
click-plugins = ">=1.1.1"
JuniorJPDJ's avatar
JuniorJPDJ committed
315
click-repl = ">=0.2.0"
316
importlib-metadata = {version = ">=1.4.0", markers = "python_version < \"3.8\""}
JuniorJPDJ's avatar
JuniorJPDJ committed
317
318
kombu = ">=5.2.3,<6.0"
pytz = ">=2021.3"
319
320
321
322
323
vine = ">=5.0.0,<6.0"

[package.extras]
arangodb = ["pyArango (>=1.3.2)"]
auth = ["cryptography"]
JuniorJPDJ's avatar
JuniorJPDJ committed
324
azureblockblob = ["azure-storage-blob (==12.9.0)"]
325
326
327
328
329
330
331
332
333
brotli = ["brotli (>=1.0.0)", "brotlipy (>=0.7.0)"]
cassandra = ["cassandra-driver (<3.21.0)"]
consul = ["python-consul2"]
cosmosdbsql = ["pydocumentdb (==2.3.2)"]
couchbase = ["couchbase (>=3.0.0)"]
couchdb = ["pycouchdb"]
django = ["Django (>=1.11)"]
dynamodb = ["boto3 (>=1.9.178)"]
elasticsearch = ["elasticsearch"]
JuniorJPDJ's avatar
JuniorJPDJ committed
334
335
eventlet = ["eventlet (>=0.32.0)"]
gevent = ["gevent (>=1.5.0)"]
336
337
librabbitmq = ["librabbitmq (>=1.5.0)"]
memcache = ["pylibmc"]
JuniorJPDJ's avatar
JuniorJPDJ committed
338
mongodb = ["pymongo[srv] (>=3.11.1)"]
339
340
341
342
msgpack = ["msgpack"]
pymemcache = ["python-memcached"]
pyro = ["pyro4"]
pytest = ["pytest-celery"]
JuniorJPDJ's avatar
JuniorJPDJ committed
343
redis = ["redis (>=3.4.1,!=4.0.0,!=4.0.1)"]
344
345
346
347
s3 = ["boto3 (>=1.9.125)"]
slmq = ["softlayer-messaging (>=1.0.3)"]
solar = ["ephem"]
sqlalchemy = ["sqlalchemy"]
JuniorJPDJ's avatar
JuniorJPDJ committed
348
sqs = ["kombu"]
349
350
351
352
353
354
355
356
357
358
359
360
361
362
363
364
365
366
367
368
369
370
371
372
373
374
375
376
377
378
379
380
381
382
383
384
385
386
387
388
389
390
tblib = ["tblib (>=1.3.0)", "tblib (>=1.5.0)"]
yaml = ["PyYAML (>=3.10)"]
zookeeper = ["kazoo (>=1.3.1)"]
zstd = ["zstandard"]

[[package]]
name = "certifi"
version = "2021.10.8"
description = "Python package for providing Mozilla's CA Bundle."
category = "main"
optional = false
python-versions = "*"

[[package]]
name = "cffi"
version = "1.15.0"
description = "Foreign Function Interface for Python calling C code."
category = "main"
optional = false
python-versions = "*"

[package.dependencies]
pycparser = "*"

[[package]]
name = "channels"
version = "3.0.4"
description = "Brings async, event-driven capabilities to Django. Django 2.2 and up only."
category = "main"
optional = false
python-versions = ">=3.6"

[package.dependencies]
asgiref = ">=3.3.1,<4"
daphne = ">=3.0,<4"
Django = ">=2.2"

[package.extras]
tests = ["pytest", "pytest-django", "pytest-asyncio", "async-timeout", "coverage (>=4.5,<5.0)"]

[[package]]
name = "channels-redis"
391
version = "3.4.0"
392
393
394
description = "Redis-backed ASGI channel layer implementation"
category = "main"
optional = false
395
python-versions = ">=3.7"
396
397
398
399
400
401
402
403
404
405
406
407
408

[package.dependencies]
aioredis = ">=1.0,<2.0"
asgiref = ">=3.2.10,<4"
channels = "<4"
msgpack = ">=1.0,<2.0"

[package.extras]
cryptography = ["cryptography (>=1.3.0)"]
tests = ["cryptography (>=1.3.0)", "pytest", "pytest-asyncio (==0.14.0)", "async-generator", "async-timeout"]

[[package]]
name = "charset-normalizer"
409
version = "2.0.12"
410
411
412
413
414
415
416
417
418
419
description = "The Real First Universal Charset Detector. Open, modern and actively maintained alternative to Chardet."
category = "main"
optional = false
python-versions = ">=3.5.0"

[package.extras]
unicode_backport = ["unicodedata2"]

[[package]]
name = "click"
420
version = "8.1.3"
421
422
423
description = "Composable command line interface toolkit"
category = "main"
optional = false
424
python-versions = ">=3.7"
JuniorJPDJ's avatar
JuniorJPDJ committed
425
426
427
428

[package.dependencies]
colorama = {version = "*", markers = "platform_system == \"Windows\""}
importlib-metadata = {version = "*", markers = "python_version < \"3.8\""}
429
430
431

[[package]]
name = "click-didyoumean"
Georg Krause's avatar
Georg Krause committed
432
433
version = "0.3.0"
description = "Enables git-like *did-you-mean* feature in click"
434
435
category = "main"
optional = false
Georg Krause's avatar
Georg Krause committed
436
python-versions = ">=3.6.2,<4.0.0"
437
438

[package.dependencies]
Georg Krause's avatar
Georg Krause committed
439
click = ">=7"
440
441
442
443
444
445
446
447
448
449
450
451
452
453
454
455
456
457
458
459
460
461
462
463
464
465
466
467
468
469
470
471
472
473
474
475
476
477
478
479
480
481
482
483
484
485

[[package]]
name = "click-plugins"
version = "1.1.1"
description = "An extension module for click to enable registering CLI commands via setuptools entry-points."
category = "main"
optional = false
python-versions = "*"

[package.dependencies]
click = ">=4.0"

[package.extras]
dev = ["pytest (>=3.6)", "pytest-cov", "wheel", "coveralls"]

[[package]]
name = "click-repl"
version = "0.2.0"
description = "REPL plugin for Click"
category = "main"
optional = false
python-versions = "*"

[package.dependencies]
click = "*"
prompt-toolkit = "*"
six = "*"

[[package]]
name = "colorama"
version = "0.4.4"
description = "Cross-platform colored terminal text."
category = "main"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*"

[[package]]
name = "constantly"
version = "15.1.0"
description = "Symbolic constants in Python"
category = "main"
optional = false
python-versions = "*"

[[package]]
name = "coverage"
486
version = "6.4.1"
487
488
489
description = "Code coverage measurement for Python"
category = "dev"
optional = false
490
python-versions = ">=3.7"
491

492
[package.dependencies]
493
tomli = {version = "*", optional = true, markers = "python_full_version <= \"3.11.0a6\" and extra == \"toml\""}
494

495
[package.extras]
496
toml = ["tomli"]
497
498
499

[[package]]
name = "cryptography"
500
version = "36.0.2"
501
502
503
504
505
506
507
508
509
510
511
512
513
514
515
516
517
518
519
520
521
522
523
524
525
526
527
528
529
530
531
532
533
534
535
536
537
538
539
540
541
542
543
544
545
546
547
548
549
550
551
552
553
554
555
556
557
558
559
560
561
562
563
564
description = "cryptography is a package which provides cryptographic recipes and primitives to Python developers."
category = "main"
optional = false
python-versions = ">=3.6"

[package.dependencies]
cffi = ">=1.12"

[package.extras]
docs = ["sphinx (>=1.6.5,!=1.8.0,!=3.1.0,!=3.1.1)", "sphinx-rtd-theme"]
docstest = ["pyenchant (>=1.6.11)", "twine (>=1.12.0)", "sphinxcontrib-spelling (>=4.0.1)"]
pep8test = ["black", "flake8", "flake8-import-order", "pep8-naming"]
sdist = ["setuptools_rust (>=0.11.4)"]
ssh = ["bcrypt (>=3.1.5)"]
test = ["pytest (>=6.2.0)", "pytest-cov", "pytest-subtests", "pytest-xdist", "pretend", "iso8601", "pytz", "hypothesis (>=1.11.4,!=3.79.2)"]

[[package]]
name = "daphne"
version = "3.0.2"
description = "Django ASGI (HTTP/WebSocket) server"
category = "main"
optional = false
python-versions = ">=3.6"

[package.dependencies]
asgiref = ">=3.2.10,<4"
autobahn = ">=0.18"
twisted = {version = ">=18.7", extras = ["tls"]}

[package.extras]
tests = ["hypothesis (==4.23)", "pytest (>=3.10,<4.0)", "pytest-asyncio (>=0.8,<1.0)"]

[[package]]
name = "decorator"
version = "5.1.1"
description = "Decorators for Humans"
category = "main"
optional = false
python-versions = ">=3.5"

[[package]]
name = "defusedxml"
version = "0.7.1"
description = "XML bomb protection for Python stdlib modules"
category = "main"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*"

[[package]]
name = "deprecated"
version = "1.2.13"
description = "Python @deprecated decorator to deprecate old python classes, functions or methods."
category = "main"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*"

[package.dependencies]
wrapt = ">=1.10,<2"

[package.extras]
dev = ["tox", "bump2version (<1)", "sphinx (<2)", "importlib-metadata (<3)", "importlib-resources (<4)", "configparser (<5)", "sphinxcontrib-websupport (<2)", "zipp (<2)", "PyTest (<5)", "PyTest-Cov (<2.6)", "pytest", "pytest-cov"]

[[package]]
name = "django"
565
version = "3.2.13"
566
567
568
569
570
571
572
573
574
575
576
577
578
579
580
581
description = "A high-level Python Web framework that encourages rapid development and clean, pragmatic design."
category = "main"
optional = false
python-versions = ">=3.6"

[package.dependencies]
asgiref = ">=3.3.2,<4"
pytz = "*"
sqlparse = ">=0.2.2"

[package.extras]
argon2 = ["argon2-cffi (>=19.1.0)"]
bcrypt = ["bcrypt"]

[[package]]
name = "django-allauth"
582
version = "0.51.0"
583
584
585
586
587
588
589
description = "Integrated set of Django applications addressing authentication, registration, account management as well as 3rd party (social) account authentication."
category = "main"
optional = false
python-versions = "*"

[package.dependencies]
Django = ">=2.0"
590
pyjwt = {version = ">=1.7", extras = ["crypto"]}
591
592
593
594
595
596
python3-openid = ">=3.0.8"
requests = "*"
requests-oauthlib = ">=0.3.0"

[[package]]
name = "django-auth-ldap"
597
version = "4.0.0"
598
599
600
601
602
603
604
605
606
description = "Django LDAP authentication backend."
category = "main"
optional = false
python-versions = ">=3.6"

[package.dependencies]
Django = ">=2.2"
python-ldap = ">=3.1"

607
608
609
610
611
612
613
614
615
616
617
[[package]]
name = "django-cache-memoize"
version = "0.1.10"
description = "Django utility for a memoization decorator that uses the Django cache framework."
category = "main"
optional = false
python-versions = ">=3.5"

[package.extras]
dev = ["flake8", "tox", "twine", "therapist", "black"]

618
619
620
621
622
623
624
625
626
627
628
629
630
631
632
633
[[package]]
name = "django-cacheops"
version = "6.0"
description = "A slick ORM cache with automatic granular event-driven invalidation for Django."
category = "main"
optional = false
python-versions = ">=3.5"

[package.dependencies]
django = ">=2.1"
funcy = ">=1.8,<2.0"
redis = ">=3.0.0"
six = ">=1.4.0"

[[package]]
name = "django-cleanup"
634
version = "6.0.0"
635
636
637
638
639
640
641
description = "Deletes old files."
category = "main"
optional = false
python-versions = "*"

[[package]]
name = "django-cors-headers"
642
version = "3.11.0"
643
644
645
description = "django-cors-headers is a Django application for handling the server headers required for Cross-Origin Resource Sharing (CORS)."
category = "main"
optional = false
646
python-versions = ">=3.7"
647
648
649
650
651
652

[package.dependencies]
Django = ">=2.2"

[[package]]
name = "django-coverage-plugin"
653
version = "2.0.3"
654
655
656
657
658
659
660
661
662
663
664
665
666
667
668
669
670
671
672
673
674
675
676
description = "Django template coverage.py plugin"
category = "dev"
optional = false
python-versions = "*"

[package.dependencies]
coverage = "*"
six = ">=1.4.0"

[[package]]
name = "django-debug-toolbar"
version = "3.2.4"
description = "A configurable set of panels that display various debug information about the current request/response."
category = "dev"
optional = false
python-versions = ">=3.6"

[package.dependencies]
Django = ">=2.2"
sqlparse = ">=0.2.0"

[[package]]
name = "django-dynamic-preferences"
677
version = "1.12.0"
678
679
680
681
682
683
684
685
686
687
688
689
description = "Dynamic global and instance settings for your django project"
category = "main"
optional = false
python-versions = "*"

[package.dependencies]
django = ">=1.11"
persisting-theory = ">=0.2.1"
six = "*"

[[package]]
name = "django-environ"
690
691
version = "0.8.1"
description = "A package that allows you to utilize 12factor inspired environment variables to configure your Django application."
692
693
category = "main"
optional = false
694
695
696
697
698
699
python-versions = ">=3.4,<4"

[package.extras]
develop = ["coverage[toml] (>=5.0a4)", "pytest (>=4.6.11)", "furo (>=2021.8.17b43,<2021.9.0)", "sphinx (>=3.5.0)", "sphinx-notfound-page"]
docs = ["furo (>=2021.8.17b43,<2021.9.0)", "sphinx (>=3.5.0)", "sphinx-notfound-page"]
testing = ["coverage[toml] (>=5.0a4)", "pytest (>=4.6.11)"]
700
701
702

[[package]]
name = "django-filter"
703
version = "21.1"
704
705
706
description = "Django-filter is a reusable Django application for allowing users to filter querysets dynamically."
category = "main"
optional = false
707
python-versions = ">=3.6"
708
709
710
711
712
713

[package.dependencies]
Django = ">=2.2"

[[package]]
name = "django-oauth-toolkit"
714
version = "1.7.1"
715
716
717
718
719
720
description = "OAuth2 Provider for Django"
category = "main"
optional = false
python-versions = "*"

[package.dependencies]
721
django = ">=2.2,<4.0.0 || >4.0.0"
722
723
724
725
726
727
jwcrypto = ">=0.8.0"
oauthlib = ">=3.1.0"
requests = ">=2.13.0"

[[package]]
name = "django-redis"
728
version = "5.2.0"
729
730
731
732
733
734
735
description = "Full featured redis cache backend for Django."
category = "main"
optional = false
python-versions = ">=3.6"

[package.dependencies]
Django = ">=2.2"
736
737
738
739
redis = ">=3,<4.0.0 || >4.0.0,<4.0.1 || >4.0.1"

[package.extras]
hiredis = ["redis[hiredis] (>=3,!=4.0.0,!=4.0.1)"]
740
741
742
743
744
745
746
747
748
749
750
751
752
753
754
755
756
757
758

[[package]]
name = "django-rest-auth"
version = "0.9.5"
description = "Create a set of REST API endpoints for Authentication and Registration"
category = "main"
optional = false
python-versions = "*"

[package.dependencies]
Django = ">=1.8.0"
djangorestframework = ">=3.1.3"
six = ">=1.9.0"

[package.extras]
with_social = ["django-allauth (>=0.25.0)"]

[[package]]
name = "django-storages"
759
version = "1.12.3"
760
761
762
763
764
765
766
767
768
description = "Support for many storage backends in Django"
category = "main"
optional = false
python-versions = ">=3.5"

[package.dependencies]
Django = ">=2.2"

[package.extras]
769
azure = ["azure-storage-blob (>=12.0.0)"]
770
771
boto3 = ["boto3 (>=1.4.4)"]
dropbox = ["dropbox (>=7.2.1)"]
772
google = ["google-cloud-storage (>=1.27.0)"]
773
774
775
776
777
778
779
780
781
782
783
784
785
786
787
788
789
libcloud = ["apache-libcloud"]
sftp = ["paramiko"]

[[package]]
name = "django-versatileimagefield"
version = "2.2"
description = "A drop-in replacement for django's ImageField that provides a flexible, intuitive and easily-extensible interface for creating new images from the one assigned to the field."
category = "main"
optional = false
python-versions = "*"

[package.dependencies]
Pillow = ">=2.4.0"
python-magic = ">=0.4.15,<1.0.0"

[[package]]
name = "djangorestframework"
790
version = "3.13.1"
791
792
793
description = "Web APIs for Django, made easy."
category = "main"
optional = false
794
python-versions = ">=3.6"
795
796
797

[package.dependencies]
django = ">=2.2"
798
pytz = "*"
799

Georg Krause's avatar
Georg Krause committed
800
801
[[package]]
name = "drf-spectacular"
802
version = "0.22.1"
Georg Krause's avatar
Georg Krause committed
803
804
805
806
807
808
809
810
811
812
813
814
815
816
817
818
819
820
description = "Sane and flexible OpenAPI 3 schema generation for Django REST framework"
category = "dev"
optional = false
python-versions = ">=3.6"

[package.dependencies]
Django = ">=2.2"
djangorestframework = ">=3.10"
inflection = ">=0.3.1"
jsonschema = ">=2.6.0"
PyYAML = ">=5.1"
typing-extensions = {version = "*", markers = "python_version < \"3.8\""}
uritemplate = ">=2.0.0"

[package.extras]
offline = ["drf-spectacular-sidecar"]
sidecar = ["drf-spectacular-sidecar"]

821
822
823
824
825
826
827
828
829
830
831
832
833
834
835
836
837
[[package]]
name = "factory-boy"
version = "3.2.1"
description = "A versatile test fixtures replacement based on thoughtbot's factory_bot for Ruby."
category = "dev"
optional = false
python-versions = ">=3.6"

[package.dependencies]
Faker = ">=0.7.0"

[package.extras]
dev = ["coverage", "django", "flake8", "isort", "pillow", "sqlalchemy", "mongoengine", "wheel (>=0.32.0)", "tox", "zest.releaser"]
doc = ["sphinx", "sphinx-rtd-theme", "sphinxcontrib-spelling"]

[[package]]
name = "faker"
838
version = "13.13.0"
839
840
841
842
843
844
845
description = "Faker is a Python package that generates fake data for you."
category = "dev"
optional = false
python-versions = ">=3.6"

[package.dependencies]
python-dateutil = ">=2.4"
846
typing-extensions = {version = ">=3.10.0.2", markers = "python_version < \"3.8\""}
847
848
849

[[package]]
name = "feedparser"
850
version = "6.0.10"
851
852
853
854
855
856
857
858
859
860
861
862
863
864
865
866
867
868
869
870
871
872
873
874
description = "Universal feed parser, handles RSS 0.9x, RSS 1.0, RSS 2.0, CDF, Atom 0.3, and Atom 1.0 feeds"
category = "main"
optional = false
python-versions = ">=3.6"

[package.dependencies]
sgmllib3k = "*"

[[package]]
name = "flake8"
version = "3.9.2"
description = "the modular source code checker: pep8 pyflakes and co"
category = "dev"
optional = false
python-versions = "!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*,>=2.7"

[package.dependencies]
importlib-metadata = {version = "*", markers = "python_version < \"3.8\""}
mccabe = ">=0.6.0,<0.7.0"
pycodestyle = ">=2.7.0,<2.8.0"
pyflakes = ">=2.3.0,<2.4.0"

[[package]]
name = "frozendict"
875
version = "2.3.0"
876
877
878
879
880
description = "A simple immutable dictionary"
category = "main"
optional = false
python-versions = ">=3.6"

881
882
883
884
885
886
887
888
[[package]]
name = "frozenlist"
version = "1.3.0"
description = "A list-like structure which implements collections.abc.MutableSequence"
category = "main"
optional = false
python-versions = ">=3.7"

889
890
891
892
893
894
895
896
897
898
899
900
901
902
903
904
905
906
907
908
909
910
[[package]]
name = "funcy"
version = "1.17"
description = "A fancy and practical functional tools"
category = "main"
optional = false
python-versions = "*"

[[package]]
name = "gunicorn"
version = "20.1.0"
description = "WSGI HTTP Server for UNIX"
category = "main"
optional = false
python-versions = ">=3.5"

[package.extras]
eventlet = ["eventlet (>=0.24.1)"]
gevent = ["gevent (>=1.4.0)"]
setproctitle = ["setproctitle"]
tornado = ["tornado (>=0.2)"]

911
912
913
914
915
916
917
918
919
920
921
[[package]]
name = "h11"
version = "0.13.0"
description = "A pure-Python, bring-your-own-I/O implementation of HTTP/1.1"
category = "main"
optional = false
python-versions = ">=3.6"

[package.dependencies]
typing-extensions = {version = "*", markers = "python_version < \"3.8\""}

922
923
924
925
926
927
928
929
[[package]]
name = "hiredis"
version = "2.0.0"
description = "Python wrapper for hiredis"
category = "main"
optional = false
python-versions = ">=3.6"

930
931
[[package]]
name = "httptools"
932
version = "0.4.0"
933
934
935
description = "A collection of framework independent HTTP protocol utils."
category = "main"
optional = false
JuniorJPDJ's avatar
JuniorJPDJ committed
936
python-versions = ">=3.5.0"
937
938

[package.extras]
JuniorJPDJ's avatar
JuniorJPDJ committed
939
test = ["Cython (>=0.29.24,<0.30.0)"]
940

941
942
943
944
945
946
947
948
949
950
951
952
953
954
955
956
957
958
959
960
961
[[package]]
name = "hyperlink"
version = "21.0.0"
description = "A featureful, immutable, and correct URL for Python."
category = "main"
optional = false
python-versions = ">=2.6, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*"

[package.dependencies]
idna = ">=2.5"

[[package]]
name = "idna"
version = "3.3"
description = "Internationalized Domain Names in Applications (IDNA)"
category = "main"
optional = false
python-versions = ">=3.5"

[[package]]
name = "importlib-metadata"
962
version = "4.11.3"
963
964
965
description = "Read metadata from Python packages"
category = "main"
optional = false
Georg Krause's avatar
Georg Krause committed
966
python-versions = ">=3.7"
967
968
969
970
971
972

[package.dependencies]
typing-extensions = {version = ">=3.6.4", markers = "python_version < \"3.8\""}
zipp = ">=0.5"

[package.extras]
973
docs = ["sphinx", "jaraco.packaging (>=9)", "rst.linker (>=1.9)"]
974
perf = ["ipython"]
975
testing = ["pytest (>=6)", "pytest-checkdocs (>=2.4)", "pytest-flake8", "pytest-cov", "pytest-enabler (>=1.0.1)", "packaging", "pyfakefs", "flufl.flake8", "pytest-perf (>=0.9.2)", "pytest-black (>=0.3.7)", "pytest-mypy (>=0.9.1)", "importlib-resources (>=1.3)"]
Georg Krause's avatar
Georg Krause committed
976
977
978

[[package]]
name = "importlib-resources"
979
version = "5.6.0"
Georg Krause's avatar
Georg Krause committed
980
981
982
description = "Read resources from Python packages"
category = "dev"
optional = false
983
python-versions = ">=3.7"
Georg Krause's avatar
Georg Krause committed
984
985
986
987
988

[package.dependencies]
zipp = {version = ">=3.1.0", markers = "python_version < \"3.10\""}

[package.extras]
989
990
docs = ["sphinx", "jaraco.packaging (>=9)", "rst.linker (>=1.9)"]
testing = ["pytest (>=6)", "pytest-checkdocs (>=2.4)", "pytest-flake8", "pytest-cov", "pytest-enabler (>=1.0.1)", "pytest-black (>=0.3.7)", "pytest-mypy (>=0.9.1)"]
991
992
993
994
995
996
997
998
999
1000

[[package]]
name = "incremental"
version = "21.3.0"
description = "A small library that versions your Python projects."
category = "main"
optional = false
python-versions = "*"

[package.extras]
For faster browsing, not all history is shown. View entire blame